Friday, 24 June 2016

hybris build error wrong java version found


if you got wrong  java version means  you are using two different java versions in your environment.

     How to see your hybris java version supported

go to  following folder 

  hybris/bin/platform/resources/ant

in this folder you find  util.xml file in that  file   230 t0 245 lines contain your java vesion 

if in your system java version is miss matched to that version ant will through build error
<condition>
    <not>
        <antversion atleast="1.9.1" />
</not>
</condition>
</fail>
     <if>
<not>
                    <or>
     <contains string="${java.version}" substring="1.7" />
                   </or>
</not>
   <then>
<fail>-

if  your using  1.8 change 1.7 to 1.8 build error will be removed 
   <condition>
     <not>
         <antversion atleast="1.9.1" />
</not>
   </condition>
</fail>
     <if>
<not>
                    <or>
     <contains string="${java.version}" substring="1.8" />
                   </or>
</not>
   <then>

<fail>-
which version your using  just mention in substrin="yourjavaverson" buid will success

1 comment:

  1. Thanks for the post, I am techno savvy. I believe you hit the nail right on the head. I am highly impressed with your blog. It is very nicely explained. Your article adds best knowledge to our Java Online Training from India. or learn thru Java EE Online Training Students.

    ReplyDelete